倍量过左峰选股公式,找到起爆点

左峰简单来说就是前期拉升形成的波段高点,左峰之后是回调,形成凹口,过左峰就是突破前期波段高点。从左峰的数量上,有过一峰、二峰、三峰等;从量价上,有倍量过左峰、缩量过左峰等。本文编写倍量过左峰选股公式,倍量过左峰是以昨天两倍或两倍以上的成交量突破前面的波段高点。

 

一、倍量过左峰主图指标公式

思路:对于倍量过左峰的描述,从编写指标公式的角度来说有一些难度,因为行情多种多样,回调的时间有多长是不确定的。本文采用30日新高,以突破30日新高那天的最高价为基础条件,再加上倍量、突破前的幅度以及突破K线的限制条件,发出信号。多少日新高N和多少倍量M做成了参数,可以根据需求修改调整。

N:=30;{参数,多少日新高}

M:=2;{参数,多少倍量}

CXG:=H=HHV(H,N);{30日新高}

T:=BARSLAST(CXG);{上一次30日新高距离当前的周期数}

HH:=REF(H,T);{30日新高那天的最高价}

HH30:=HHV(H,30);{30日最高价的最高值}

LL30:=LLV(L,30);{30日最低价的最低值}

HL:=(HH30-LL30)/LL30*100;{30日高低点幅度}

A1:=CROSS(C,REF(HH,1));{过左峰}

A2:=V/REF(V,1)>=M;{倍量}

A3:=C/REF(C,1)>1.03 AND (C-L)/(H-L)>0.6;{涨幅大于3%的阳线}

A4:=REF(HL<20,1);{一日前的30日高低点幅度小于20%}

XG:=A1 AND A2 AND A3 AND A4;

STICKLINE(XG,H,L,0,0),COLORYELLOW;

STICKLINE(XG,O,C,3,0),COLORYELLOW;

DRAWICON(XG,L,1);

 

 

二、倍量过左峰选股公式

N:=30;

M:=2;

CXG:=H=HHV(H,N);

T:=BARSLAST(CXG);

HH:=REF(H,T);

HH30:=HHV(H,30);

LL30:=LLV(L,30);

HL:=(HH30-LL30)/LL30*100;

A1:=CROSS(C,REF(HH,1));

A2:=V/REF(V,1)>=M;

A3:=C/REF(C,1)>1.03 AND (C-L)/(H-L)>0.6;

A4:=REF(HL<20,1);

XG:A1 AND A2 AND A3 AND A4;

三、注意点

左峰之后调整的时间有长有短,30日新高并不能完全匹配所有行情,这就导致有些信号明显不符合,一眼就能就看出来。另外每个人对行情可能有不同的理解,可以自行调整参数或者修改代码。最后就是假突破的问题了,我觉得假突破是回避不了的,只能通过止损、资金管理等方法改善。

关注技术Pie,学习更多通达信指标公式编写知识。版权所有,转载请注明出处。

友情提醒:本文仅供学习交流技术指标公式,不构成任何投资建议。投资有风险,入市需谨慎。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>