CentOS 7虚拟机 虚拟机安装安装增强VBox_GAs_6.1.22失败:modprobe vboxguest failed

我安装的CentOS

 在安装增强工具的时候报错:

查阅资料后 ,解决方法:

1、更新kernel内核版本:

yum update kernel -y

//安装kernel-devel和gcc编译工具链

yum install -y kernel-devel gcc



//更新kernel和kernel-devel到最新版本

yum -y upgrade kernel kernel-devel 

 
内核卸载参考:内核更新及删除
2、安装kernel header:

yum install kernel-headers kernel-devel gcc make -y

 
3、打开安装增强的iso文件,启动对应版本型号的脚本文件
linux的为:

sudo sh VBoxLinuxAddition.sh

4、重新启动, 重启时,选择最新版本的内核启动

reboot

 

上图最后一个选项急救模式启动(系统出项问题不能正常启动时使用并修复系统)

上图前面几个选项都是正常启动。显示的是内核的版本,如果出现多个,说明你有升级过内核;CentOs升级内核后,旧的内核是不会自动删除,所以才有多个正常启动选项,让你选择用哪个内核来启动

1、首先列出系统中正在使用的内核:
uname -a

2、查询系统中全部的内核
rpm -qa | grep kernel

3、将你想删除的内核删除掉(例如,在我的系统中,我要删掉kernel-3.10.0-229.4.2.el7.x86_64的内核,需要把所有含有kernel-3.10.0-229.4.2.el7.x86_64字样的全部删掉)

yum remove kernel-3.10.0-229.4.2.el7.x86_64

yum remove kernel-tools-libs-3.10.0-229.4.2.el7.x86_64 

3、查看内核列表

rpm -qa | grep kernel | grep core
 
4、查看系统当前内核版本

uname -a
 
5、手动删除某个内核版本来减少开启启动项**(注意不要删除当前内核版本)**

yum remove kernel-core-4.18.0-193.el8.x86_64
 
5、重启系统

reboot 

5、查看当前启动的内核版本

uname -r 

 6、移除旧的内核

yum remove 旧版本内核 

7、视图-》 无缝模式    虚拟机设置共享粘贴板、拖放(以VirtualBox为例)
设备->共享粘贴板(拖放)->勾选双向 

 

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>