Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath ‘./lib/tokenize‘ is not defined by “exports“

Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: Package subpath ‘./lib/tokenize’ is not defined by “exports” in the package.json of a module in node_modules

今天在启动一个react项目的时候,我运行了这个命令:

npm run start

项目启动过程中,控制台突然报了这个错误
在这里插入图片描述

原因:
原来是我当时安装这个项目需要的依赖的时候,使用的node版本比较低,最近升级了一下node版本导致的。

解决办法:

第一种办法:将当前的node版本切回到当时安装项目依赖的时候的版本,这样的话再运行npm run start命令就不会再报错了;

第二种办法:删除已经安装好的node_modules文件夹、package-lock.json文件或者 yarn.lock文件;重新在升级后的node环境下执行npm i或者yarn install,重新下载项目所需要的依赖就好了;

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>