Gradle版本、Gradle插件版本和AndroidStudio版本之间的对应关系

问题描述

有时候碰到gradle版本死活下载不下来,还会报Gralde Sync Issues,有可能是你的Gradle Wrapper版本和Gradle插件版本、AndroidStudio版本不匹配。
在这里插入图片描述

解决方案

Gradle版本和Gradle插件版本之间存在一定的对应关系。Gradle Wrapper是用来指定项目使用的Gradle版本,Gradle插件则是用来构建Android应用程序的。

Android Gradle 插件版本所需的 Gradle 版本

下表列出了各个 Android Gradle 插件版本所需的 Gradle 版本:

插件版本 所需的最低 Gradle 版本
8.2 8.1
8.0 8.0
7.4 7.5
7.3 7.4
7.2 7.3.3
7.1 7.2
7.0 7.0
4.2.0+ 6.7.1

要指定Gradle Wrapper版本,请打开项目根目录的 gradle/wrapper/gradle-wrapper.properties 文件,并将 distributionUrl 属性设置为要使用的Gradle版本的下载链接。例如:

distributionUrl=https://services.gradle.org/distributions/gradle-7.2-bin.zip

要指定Gradle插件版本,请在项目层级的 build.gradle 文件中修改以下属性:

   dependencies {
       classpath 'com.android.tools.build:gradle:7.1.3'
   }

Android Gradle 插件和 Android Studio 兼容性

下表列出了各个 Android Studio 版本所需的 Android Gradle 插件版本。

Android Studio 版本 所需插件版本
Hedgehog 2023.1.1 3.2-8.2
Giraffe 2022.3.1 3.2-8.1
Flamingo 2022.2.1 3.2-8.0
Electric Eel 2022.1.1 3.2-7.4
Dolphin 2021.3.1 3.2-7.3
Chipmunk 2021.2.1 3.2-7.2
Bumblebee 2021.1.1 3.2-7.1
Arctic Fox 2020.3.1 3.1-7.0

改为匹配的版本关系后,点一下Sync Project with Gradle Files ,发现就下载成功项目可以正常运行起来了。

参考安卓官方文档:https://developer.android.com/studio/releases/gradle-plugin?hl=zh-cn#updating-plugin

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>