用VScode+anaconda搭建Python环境

Python的IDE有很多,自带的IDLE,spyder,pycharm等都可以,但我目前用得最上手的是VScode,搭载anaconda,优点就是写代码效率高,第三方库导入一次性到位。下面介绍安装和配置教程。

  • 安装VS code(细节可以参考别人的安装教程,我忘了一些安装细节了)

  • 打开VScode,点左边的扩展,搜索Chinese,下载中文包

  • 搜索Python,下载Python插件

  • 关闭VScode,新建一个文件夹,用于专门存放你的Python代码
  • Anaconda下载,这个可以B站上找一个安装教程,我也忘了当时安装时要点哪些了,但好像有要把它的环境变量加上
  • Anaconda安装完成之后,打开VScode,左上角的文件->打开文件夹->选择最开始新建的那个文件夹,然后点文件夹旁边第一个文件图标的按钮新建文件

文件名为“文件名.py”,回车成功创建。

  • 输入一些代码

import numpy as np
print("Hello,world!")
c=[1]*10
print(c)
  • 左上角运行,启动调试和非调试运行都可以

  • 然后好像会出现选择编译器,选择我鼠标停留的那个蓝色选址

路径后面一定要是Anaconda3python.exe,可以确认一下。

       (我的launch.json文档内容如下:)

{
    // 使用 IntelliSense 了解相关属性。 
    // 悬停以查看现有属性的描述。
    // 欲了解更多信息,请访问: https://go.microsoft.com/fwlink/?linkid=830387
    "version": "0.2.0",
    "configurations": [
        {
            "name": "Python: Current File",
            "type": "python",
            "request": "launch",
            "program": "${file}",
            "console": "externalTerminal",
            "justMyCode": true
        }
    ]
}
  • 然后应该就能运行成功了,我的效果如下

另外,如果出现问题“DLL load failed while importing _multiarray_umath: 找不到指定的模块“,

那本程序就是导入的numpy版本比较旧,与python3.9不匹配,需要更新

解决如下(以numpy为例)

如上图,Windows菜单中找到Anaconda3,打开我选的那个prompt,

以numpy包为例,

输入pip install numpy==较高版本

如pip install numpy==2.0

这里红字表示版本过高,然后后面会显示现有的版本号,下图所示,最后面的即最新的版本,

这里我是选择的1.23,即输入pip install numpy==1.23

这会用国外的源,但下载速度会非常慢,如果想下载快一点,可以用国内的镜像试试,

即输入pip install numpy==1.23 -o 网址

这里网址可以选以下任意一个

豆瓣:

http://pypi.douban.com/simple

阿里(推荐)

http://mirrors.aliyun.com/pypi/simple

清华(推荐)

https://pypi.tuna.tsinghua.edu.cn/simple

华中理工大学

http://pypi.hustunique.com/simple

山东理工大学

http://pypi.sdutlinux.org/simple

中国科学技术大学(推荐)

http://pypi.mirrors.ustc.edu.cn/simple

输入示例:

pip install numpy==1.23 -o Simple Index

下载完后,不管它报不报错,如果有类似下面的信息,即可关掉命令提示符,重新运行代码

如果还有其他问题,可以在CSDN或者B站搜索更多相关问题

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>