Android Gradle 构建脚本中使用了不安全的协议

Using insecure protocols with repositories, without explicit opt-in, is unsupported. Switch Maven repository 'maven5(http://maven.aliyun.com/nexus/content/groups/public)' to redirect to a secure protocol (like HTTPS) or allow insecure protocols. See https://docs.gradle.org/7.2/dsl/org.gradle.api.artifacts.repositories.UrlArtifactRepository.html#org.gradle.api.artifacts.repositories.UrlArtifactRepository:allowInsecureProtocol for more details.

这个警告表明在你的 Gradle 构建脚本中使用了不安全的协议(例如 HTTP)来访问 Maven 仓库。Gradle 强制使用安全协议(例如 HTTPS)来访问远程仓库,以提高安全性。

要解决这个问题,你可以按照警告中提供的链接去查看文档,了解如何配置 Maven 仓库使用安全协议,或者允许使用不安全的协议。通常情况下,为了保障安全性,建议将仓库配置为使用 HTTPS。
 

 方式一:在你的 build.gradle 文件中,找到涉及到 maven.aliyun.com 的 Maven 仓库的配置,然后将其修改为使用 HTTPS,示例:

repositories {
    maven {
        url "https://maven.aliyun.com/nexus/content/groups/public"
    }
}

方式二:如果你确定你的环境下可以使用不安全的协议,你也可以选择允许不安全协议,但这并不是推荐的做法:

repositories {
    maven {
        url "http://maven.aliyun.com/nexus/content/groups/public"
        allowInsecureProtocol = true
    }
}

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>