Android 版本 对应的 API版本

Android 14(开发者预览版)

如需详细了解平台变更,请参阅 Android 14 文档

Android 13(API 级别 33)

如需详细了解平台变更,请参阅 Android 13 文档

Android 12(API 级别 31、32)

12L 功能更新(API 级别 32)

如需详细了解平台变更,请参阅 12L 文档

Android 12(API 级别 31)

如需详细了解平台变更,请参阅 Android 12 文档

Android 12 ATD 系统映像

此自动化测试设备 (ATD) 映像是针对无头自动化测试进行了优化的 Android 系统映像。早期数据表明,使用此映像的测试应该会减少模拟器进程的 CPU 和内存用量,并缩短测试的实际用时。

它通过以下方式实现性能提升:

  • 移除大多数面向用户的应用(例如拨号器、设置和 SystemUI)。
  • 停用硬件渲染程序绘制功能。

该映像有两个版本:提供 Google API 的 Google API ATD,以及提供纯 AOSP 体验的 AOSP ATD。

如需详细了解如何使用 ATD 运行测试,请参阅使用自动化测试设备运行测试

Android 11(API 级别 30)

如需详细了解平台变更,请参阅 Android 11 文档

Android 10(API 级别 29)

如需详细了解平台变更,请参阅面向开发者的 Android 10

修订版 5(2020 年 7 月)

此修订版本添加了 Android Automotive OS 桩。

Android 9(API 级别 28)

如需详细了解平台变更,请参阅面向开发者的 Android 9

修订版 1(2018 年 8 月)

已发布为稳定版(不再处于预览状态)。

Android 8.1(API 级别 27)

如需详细了解平台变更,请参阅面向开发者的 Android 8.1

修订版 1(2017 年 12 月)

已发布为稳定版(不再处于预览状态)。

Android 8.0(API 级别 26)

如需详细了解平台变更,请参阅面向开发者的 Android 8.0

修订版 2(2017 年 8 月)

Android 7.1(API 级别 25)

如需详细了解平台变更,请参阅面向开发者的 Android 7.1

修订版 3(2016 年 12 月)
修订版 2(2016 年 11 月)
修订版 1(2016 年 10 月)

Android 7.0(API 级别 24)

如需详细了解平台变更,请参阅面向开发者的 Android 7.0

修订版 1(2016 年 8 月)

Android 6.0(API 级别 23)

如需详细了解平台变更,请参阅 Android 6.0 变更和 Android 6.0 API

修订版 2(2015 年 11 月)
修订版 1(2015 年 8 月)

Android 5.1(API 级别 22)

如需详细了解平台变更,请参阅 Lollipop 概览和 Android 5.1 API 变更

修订版 1(2015 年 3 月)

Android 5.0(API 级别 21)

如需详细了解平台变更,请参阅 Lollipop 概览和 Android 5.0 API 变更

修订版 2(2014 年 12 月)
修订版 1(2014 年 10 月)

Android 4.4W(API 级别 20)

此版本使 KitKat 支持 Android Wear。

修订版 2(2014 年 10 月)
修订版 1(2014 年 6 月)

Android 4.4(API 级别 19)

如需详细了解平台变更,请参阅 KitKat 概览和 Android 4.4 API 变更

修订版 2(2013 年 12 月)
修订版 1(2013 年 10 月)

Android 4.3(API 级别 18)

如需详细了解平台变更,请参阅 Jelly Bean 概览和 Android 4.3 API 变更

修订版 2(2013 年 8 月)
修订版 1(2013 年 7 月)

Android 4.2(API 级别 17)

如需详细了解平台变更,请参阅 Jelly Bean 概览和 Android 4.2 API 变更

修订版 2(2013 年 2 月)
修订版 1(2012 年 11 月)

Android 4.1(API 级别 16)

如需详细了解平台变更,请参阅 Jelly Bean 概览和 Android 4.1 API 变更

修订版 3(2012 年 10 月)
修订版 2(2012 年 7 月)
修订版 1 (2012 年 6 月)

Android 4.0.3(API 级别 15)

修订版 3(2012 年 3 月)
修订版 2(2012 年 1 月)
修订版 1(2011 年 12 月)

Android 4.0(API 级别 14)

Android 4.0,修订版 2(2011 年 12 月)
Android 4.0,修订版 1(2011 年 10 月)

Android 3.2(API 级别 13)

Android 3.2,修订版 1(2011 年 7 月)

Android 3.1(API 级别 12)

Android 3.1,修订版 3(2011 年 7 月)
Android 3.1,修订版 2(2011 年 5 月)
Android 3.1,修订版 1(2011 年 5 月)

Android 3.0(API 级别 11)

Android 3.0,修订版 2(2011 年 7 月)
Android 3.0,修订版 1(2011 年 2 月)

Android 2.3.3(API 级别 10)

Android 2.3.3,修订版 2(2011 年 7 月)
Android 2.3.3,修订版 1(2011 年 2 月)

Android 2.3(API 级别 9)

Android 2.3,修订版 1(2010 年 12 月)

依赖项:

需要 SDK 工具 r8 或更高版本。

 BUG! exception in phase 'semantic analysis' in source unit '_BuildScript_' Unsupported class file major version 64

adb.exe: device unauthorized.

手机端需要选择一下信任。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>