【vue3】踩坑日记,vite与node版本对应(mac环境)

创建vue3+vite+ts项目时,报错The requested module ‘vue’ does not provide an export named ‘computed’;
在这里插入图片描述

node版本问题,
Vite 需要 Node.js 版本 14.18+,16+;
升级node版本步骤:
先查看node的版本:

node -v;

安装n:

npm install -g n

sudo n latest // 升级到最新版本
sudo n stable // 升级到稳定版本
sudo n xx.xx // 升级到具体版本号
我采用的是升级到14.18.2

 sudo n 14.18.2

n 切换之后的 node 默认装在 /usr/local/bin/node,先用 which node 检查一下当前使用的 node 是否在这个路径下。是的话,就更新下/etc/profile文件指定:

source /etc/profile

node就完美升级到想要的版本,vite抛错也完美解决!
在这里插入图片描述

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>