解决:java: 警告: 源发行版 17 需要目标发行版 17

问题描述:java: 警告: 源发行版 17 需要目标发行版 17

解决办法:

1.将 Settings --> Build, Execution, Deployment --> Complier --> Java Complier 配置下的 Project bytecode version: 17 改为 与 项目使用的 JDK 版本一样.

2. File-Projuect Structure

将SDK以及Language level均设置为你使用的版本

项目中有多个模块时,把对应模块的source下的Language level设置成你使用的版本

3.把Pom.xml配置文件下的java版本改为你使用的版本

到此问题解决。

 

 

 

 

 

 

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
THE END
分享
二维码
< <上一篇
下一篇>>